ANDROIDSpravodajstvo

Od budúceho roka nebude na starších Android smartfónoch možné otvoriť väčšinu internetových stránok

Zariadeniam s operačným systémom Android 7.1 Nougat a starším vyprší 1. septembra 2021 kľúčový bezpečnostný certifikát

Zavedenie nového bezpečnostného protokolu HTTPS na webových stránkach trvalo doslova roky, no ku dnešnému dňu je na väčšine webov prenos informácií zabezpečený práve vďaka modernejšiemu no najmä bezpečnejšiemu protokolu. Pri pohľade na tento fakt si však treba uvedomiť aj čiastočné „riziká“ spojené s kompatibilitou so staršími zariadeniami, ktoré určite veľká časť z nás stále používa. Ako informuje portál AndroidPolice.com, práve kompatibilita protokolu HTTPS so staršími zariadeniami môže už v budúcom roku znamenať konečnú pre veľkú časť starších zariadení s operačným systémom Android.

Ohrozené sú zariadenia s operačným systémom Android 7.1 Nougat a starším

Na trhu s bezpečnostnými protokolmi je obrovským hráčom spoločnosť Let’s Encrypt, ktorej certifikáty používa približne 30% webových domén na celom svete. Pri prvom založení nového certifikátu požiadala o začlenenie koreňového certifikátu ISRG Root X1 do všetkých internetových prehliadačov a operačných systémov. Po boku vlastného koreňového certifikátu však bola podpísaná krížová dohoda so spoločnosťou IdenTrust, ktorá využívala certifikáty od spoločnosti Let’s Encrypt aj vo svojom koreňovom certifikáte DST Root X3. Kameňom úrazu však je, že práve tento koreňový certifikát je už roky využívaný v systémoch Windows, macOS, Android ako aj vo väčšine softvérových platforiem a už v budúcom roku má dôjsť ku vypršaniu partnerstva medzi vyššie spomínanými spoločnosťami.

Partnerstvo medzi spoločnosťami Let’s Encrypt a IdenTrust vyprší 1. septembra 2021, pričom spoločnosti údajne neplánujú uzavrieť ďalšiu dohodu o spolupráci. Pre všetky prehliadače a operačné systémy bez koreňového certifikátu od spoločnosti Let’s Encrypt to teda znamená, že nebudú schopné pracovať s webovými stránkami a službami využívajúcimi najnovší HTTPS certifikát. Dotknuté sú samozrejme už práve spomínané staršie Android zariadenia s operačným systémom Android 7.1 alebo starším.

Majitelia starších zariadení nemajú moc na výber

Čo teda môžu robiť majitelia starších zariadení, aby mohli svoje smartfóny využívať naplno aj naďalej. Bohužiaľ, možností príliš veľa nie je. Čiastočne by problém mohlo vyriešiť používanie internetového prehliadača Firefox, ktorý využíva vlastné úložisko certifikátov, kde sa nachádza aj práve potrebný certifikát od spoločnosti Let’s Encrypt. Používatelia však stále môžu natrafiť na chybové hlášky pri používaní bežných aplikácií, či iných služieb. Najracionálnejším riešením je tým pádom kúpa nového zariadenia, no stále treba brať do úvahy, že Android 7.1 a nižší stále používa viac ako 30% používateľov a tento problém zrejme nebude taký kľúčový, aby sa väčšina z týchto používateľov rozhodla pre novšie zariadenie.

Prihláste sa do odberu tých najnovších informácií a správ z portálu VoSveteIt.sk

Odoslaním e-mailu dávate súhlas s podmienkami ochrany súkromia. Nezabudnite odber potvrdiť ešte v e-maile, ktorý Vám bude doručený

Mohlo by Vás zaujímať

Tagy
Close
Close